<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width,initial-scale=1.0"><link rel="pingback" href="https://gruntstuff.com/xmlrpc.php"><title>Rihanna and Drake reunite after rumored Hassan Jameel split - Gruntstuff</title><link rel="stylesheet" href="https://gruntstuff.com/wp-content/cache/min/1/71760c08c5b2f085a622a1ea9104b98a.css" data-minify="1" /><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Rihanna and Drake reunite after rumored Hassan Jameel split - Gruntstuff" /><meta property="og:description" content="Rihanna and Drake have been noticed in shut proximity to one another at Yams Day 2020 — a live performance honoring the late A$AP Mob member A$AP Yams — on Friday. Followers captured a video that exhibits the exes standing close to one another within the crowd as they took in one of many performances. &hellip;" /><meta property="og:url" content="https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/" /><meta property="og:site_name" content="Gruntstuff" /><meta property="article:section" content="General News" /><meta property="article:published_time" content="2020-03-21T05:31:27+00:00" /><meta property="article:modified_time" content="2020-03-21T05:31:28+00:00" /><meta property="og:updated_time" content="2020-03-21T05:31:28+00:00" /><meta property="og:image" content="https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?fit=1200%2C800&#038;ssl=1" /><meta property="og:image:secure_url" content="https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?fit=1200%2C800&#038;ssl=1" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="800" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Rihanna and Drake have been noticed in shut proximity to one another at Yams Day 2020 — a live performance honoring the late A$AP Mob member A$AP Yams — on Friday. Followers captured a video that exhibits the exes standing close to one another within the crowd as they took in one of many performances. [&hellip;]" /><meta name="twitter:title" content="Rihanna and Drake reunite after rumored Hassan Jameel split - Gruntstuff" /><meta name="twitter:image" content="https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?fit=1200%2C800&#038;ssl=1" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://gruntstuff.com/#website","url":"https://gruntstuff.com/","name":"Gruntstuff","inLanguage":"en-US","description":"Latest News Bulletins!","potentialAction":{"@type":"SearchAction","target":"https://gruntstuff.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?fit=1200%2C800&ssl=1","width":1200,"height":800},{"@type":"WebPage","@id":"https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/#webpage","url":"https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/","name":"Rihanna and Drake reunite after rumored Hassan Jameel split - Gruntstuff","isPartOf":{"@id":"https://gruntstuff.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/#primaryimage"},"datePublished":"2020-03-21T05:31:27+00:00","dateModified":"2020-03-21T05:31:28+00:00","author":{"@id":"https://gruntstuff.com/#/schema/person/10e67d83df894c2c1fd789309041dddf"}},{"@type":["Person"],"@id":"https://gruntstuff.com/#/schema/person/10e67d83df894c2c1fd789309041dddf","name":"Tina Sanders","image":{"@type":"ImageObject","@id":"https://gruntstuff.com/#authorlogo","inLanguage":"en-US","url":"https://gruntstuff.com/wp-content/uploads/2019/11/Tina.png","caption":"Tina Sanders"},"description":"Tina is the mind behind Gruntstuff.com, and she ideated it when she was working for an online magazine company where she used to cover US-based headlines news. She holds a degree in journalism and has more than 4.5 years of experience in an online magazine company. She had the idea while working there but when she was quite sure about starting something on her own, she took the risk and left the job to start Gruntstuff. Since then she added a few team members, and along with them, she creates General US news content on the site.","sameAs":[]}]}</script> <link rel="amphtml" href="https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/amp/" /><meta name="generator" content="AMP for WP 1.0.23"/><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Gruntstuff &raquo; Feed" href="https://gruntstuff.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Gruntstuff &raquo; Comments Feed" href="https://gruntstuff.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Gruntstuff &raquo; Rihanna and Drake reunite after rumored Hassan Jameel split Comments Feed" href="https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify}</style><link rel='stylesheet' id='herald-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%7CLato%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;ver=1.5.2' type='text/css' media='all' /><style id='herald-main-inline-css' type='text/css'>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</style><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://gruntstuff.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}</style><link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.2.1/css/jetpack.css' type='text/css' media='all' />    <link rel='https://api.w.org/' href='https://gruntstuff.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://gruntstuff.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://gruntstuff.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='https://gruntstuff.com/?p=16221' /><link rel="alternate" type="application/json+oembed" href="https://gruntstuff.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgruntstuff.com%2Frihanna-and-drake-reunite-after-rumored-hassan-jameel-split%2F16221%2F" /><link rel="alternate" type="text/xml+oembed" href="https://gruntstuff.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgruntstuff.com%2Frihanna-and-drake-reunite-after-rumored-hassan-jameel-split%2F16221%2F&#038;format=xml" /><link rel='dns-prefetch' href='//c0.wp.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/><style type='text/css'>img#wpstats{display:none}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><meta name="indi-verification" content="f3502df6" /><meta name="msvalidate.01" content="CD12270AC6CD594A97CB48A09AF3F495" /> <script data-ad-client="ca-pub-8917761949594759" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> </head><body class="post-template-default single single-post postid-16221 single-format-standard unknown herald-boxed"><div id="fb-root"></div>  <header id="header" class="herald-site-header"><div class="header-top hidden-xs hidden-sm"><div class="container"><div class="row"><div class="col-lg-12"><div class="hel-l"><nav class="secondary-navigation herald-menu"><ul id="menu-page-menu" class="menu"><li id="menu-item-205" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-205"><a href="https://gruntstuff.com/">Home</a></li><li id="menu-item-206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-206"><a href="https://gruntstuff.com/about/">About</a></li><li id="menu-item-207" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-207"><a href="https://gruntstuff.com/contact/">Contact</a></li><li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://gruntstuff.com/team/">Team</a></li><li id="menu-item-208" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208"><a href="https://gruntstuff.com/terms-of-use/">Terms of Use</a></li><li id="menu-item-209" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-209"><a href="https://gruntstuff.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-210" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-210"><a href="https://gruntstuff.com/cookie-policy/">Cookie Policy</a></li><li id="menu-item-374" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-374"><a href="https://gruntstuff.com/resources/">Resources</a></li></ul></nav></div><div class="hel-r"> <span class="herald-calendar"><i class="fa fa-calendar"></i>March 21, 2020</span></div></div></div></div></div><div class="header-middle herald-header-wraper hidden-xs hidden-sm"><div class="container"><div class="row"><div class="col-lg-12 hel-el"><div class="hel-l herald-go-hor"><div class="site-branding"> <span class="site-title h1"><a href="https://gruntstuff.com/" rel="home"><img class="herald-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Gruntstuff" data-lazy-src="https://gruntstuff.com/wp-content/uploads/2019/08/Gruntstuff_logo.png" ><noscript><img class="herald-logo" src="https://gruntstuff.com/wp-content/uploads/2019/08/Gruntstuff_logo.png" alt="Gruntstuff" ></noscript></a></span></div></div><div class="hel-r herald-go-hor"></div></div></div></div></div><div class="header-bottom herald-header-wraper hidden-sm hidden-xs"><div class="container"><div class="row"><div class="col-lg-12 hel-el"><div class="hel-l"><nav class="main-navigation herald-menu"><ul id="menu-cat-menu" class="menu"><li id="menu-item-90" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-90"><a href="https://gruntstuff.com/">Home</a><li id="menu-item-92" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92"><a href="https://gruntstuff.com/category/technology/">Technology</a><li id="menu-item-93" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-93"><a href="https://gruntstuff.com/category/general-news/">General News</a><li id="menu-item-297" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-297"><a href="https://gruntstuff.com/category/science/">Science</a></ul></nav><div class="herald-menu-popup-search"> <span class="fa fa-search"></span><div class="herald-in-popup"><form class="herald-search-form" action="https://gruntstuff.com/" method="get"> <input name="s" class="herald-search-input" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="herald-search-submit"></button></form></div></div></div><div class="hel-r"></div></div></div></div></div><div class="header-trending hidden-xs hidden-sm"><div class="container"><div class="row"><div class="col-lg-12 col-md-12"><div class="row"><div class="col-lg-2 col-md-2"><div class="herald-post-thumbnail"> <a href="https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/" title="Rihanna and Drake reunite after rumored Hassan Jameel split"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=150%2C150&amp;ssl=1" /><noscript><img width="150" height="150" src="https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><h4 class="h6"><a href="https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/">Rihanna and Drake reunite after rumored Hassan Jameel split</a></h4></div><div class="col-lg-2 col-md-2"><div class="herald-post-thumbnail"> <a href="https://gruntstuff.com/lala-kent-heres-why-she-was-not-fazed-by-50-cents-latest-diss-of-her-postponed-marriage-ceremony/16218/" title="Lala Kent – Here’s Why She Was Not Fazed By 50 Cent’s Latest Diss Of Her Postponed Marriage ceremony!"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/fofty-fifty-cent-lala-randall.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/fofty-fifty-cent-lala-randall.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/fofty-fifty-cent-lala-randall.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/fofty-fifty-cent-lala-randall.jpg?resize=150%2C150&amp;ssl=1" /><noscript><img width="150" height="150" src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/fofty-fifty-cent-lala-randall.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/fofty-fifty-cent-lala-randall.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/fofty-fifty-cent-lala-randall.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/fofty-fifty-cent-lala-randall.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><h4 class="h6"><a href="https://gruntstuff.com/lala-kent-heres-why-she-was-not-fazed-by-50-cents-latest-diss-of-her-postponed-marriage-ceremony/16218/">Lala Kent – Here’s Why She Was Not Fazed By 50 Cent’s Latest Diss Of Her Postponed Marriage ceremony!</a></h4></div><div class="col-lg-2 col-md-2"><div class="herald-post-thumbnail"> <a href="https://gruntstuff.com/elizabeth-warren-bernie-sanders-told-me-a-woman-would-not-be-elected-president/16215/" title="Elizabeth Warren: Bernie Sanders told me a woman would not be elected president"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=150%2C150&amp;ssl=1" /><noscript><img width="150" height="150" src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><h4 class="h6"><a href="https://gruntstuff.com/elizabeth-warren-bernie-sanders-told-me-a-woman-would-not-be-elected-president/16215/">Elizabeth Warren: Bernie Sanders told me a woman would not be elected president</a></h4></div><div class="col-lg-2 col-md-2"><div class="herald-post-thumbnail"> <a href="https://gruntstuff.com/high-school-basketball-coach-accused-of-groping-14-year-old-student/16212/" title="High school basketball coach accused of groping 14-year-old student"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=150%2C150&amp;ssl=1" /><noscript><img width="150" height="150" src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><h4 class="h6"><a href="https://gruntstuff.com/high-school-basketball-coach-accused-of-groping-14-year-old-student/16212/">High school basketball coach accused of groping 14-year-old student</a></h4></div><div class="col-lg-2 col-md-2"><div class="herald-post-thumbnail"> <a href="https://gruntstuff.com/porsha-williams-shares-a-video-with-baby-pj-terrorizing-her-and-fans-are-in-awe/16209/" title="Porsha Williams Shares A Video With Baby PJ Terrorizing Her And Fans Are In Awe"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?w=1054&amp;ssl=1 1054w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=1024%2C1024&amp;ssl=1 1024w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=768%2C768&amp;ssl=1 768w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=990%2C990&amp;ssl=1 990w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=150%2C150&amp;ssl=1" /><noscript><img width="150" height="150" src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?w=1054&amp;ssl=1 1054w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=1024%2C1024&amp;ssl=1 1024w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=768%2C768&amp;ssl=1 768w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=990%2C990&amp;ssl=1 990w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><h4 class="h6"><a href="https://gruntstuff.com/porsha-williams-shares-a-video-with-baby-pj-terrorizing-her-and-fans-are-in-awe/16209/">Porsha Williams Shares A Video With Baby PJ Terrorizing Her And Fans Are In Awe</a></h4></div><div class="col-lg-2 col-md-2"><div class="herald-post-thumbnail"> <a href="https://gruntstuff.com/new-surprise-woman-1984-image-shows-cheetah-maxwell-lord-together/16206/" title="New ‘Surprise Woman 1984’ Image Shows Cheetah &#038; Maxwell Lord Together"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://i1.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Wonder_Woman_1984_Gal_Gadot_Pedro_Pascal_Maxwell_Lord_Kristen_Wiig_Cheetah-1.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Wonder_Woman_1984_Gal_Gadot_Pedro_Pascal_Maxwell_Lord_Kristen_Wiig_Cheetah-1.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i1.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Wonder_Woman_1984_Gal_Gadot_Pedro_Pascal_Maxwell_Lord_Kristen_Wiig_Cheetah-1.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i1.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Wonder_Woman_1984_Gal_Gadot_Pedro_Pascal_Maxwell_Lord_Kristen_Wiig_Cheetah-1.jpg?resize=150%2C150&amp;ssl=1" /><noscript><img width="150" height="150" src="https://i1.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Wonder_Woman_1984_Gal_Gadot_Pedro_Pascal_Maxwell_Lord_Kristen_Wiig_Cheetah-1.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i1.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Wonder_Woman_1984_Gal_Gadot_Pedro_Pascal_Maxwell_Lord_Kristen_Wiig_Cheetah-1.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Wonder_Woman_1984_Gal_Gadot_Pedro_Pascal_Maxwell_Lord_Kristen_Wiig_Cheetah-1.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i1.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Wonder_Woman_1984_Gal_Gadot_Pedro_Pascal_Maxwell_Lord_Kristen_Wiig_Cheetah-1.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><h4 class="h6"><a href="https://gruntstuff.com/new-surprise-woman-1984-image-shows-cheetah-maxwell-lord-together/16206/">New ‘Surprise Woman 1984’ Image Shows Cheetah &#038; Maxwell Lord Together</a></h4></div></div></div></div></div></div></header><div id="sticky-header" class="herald-header-sticky herald-header-wraper herald-slide hidden-xs hidden-sm"><div class="container"><div class="row"><div class="col-lg-12 hel-el"><div class="hel-l herald-go-hor"><div class="site-branding mini"> <span class="site-title h1"><a href="https://gruntstuff.com/" rel="home"><img class="herald-logo-mini" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Gruntstuff" data-lazy-src="https://gruntstuff.com/wp-content/uploads/2019/08/Gruntstuff_logo.png" ><noscript><img class="herald-logo-mini" src="https://gruntstuff.com/wp-content/uploads/2019/08/Gruntstuff_logo.png" alt="Gruntstuff" ></noscript></a></span></div></div><div class="hel-r herald-go-hor"><nav class="main-navigation herald-menu"><ul id="menu-cat-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-90"><a href="https://gruntstuff.com/">Home</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92"><a href="https://gruntstuff.com/category/technology/">Technology</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-93"><a href="https://gruntstuff.com/category/general-news/">General News</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-297"><a href="https://gruntstuff.com/category/science/">Science</a></ul></nav></div></div></div></div></div><div id="herald-responsive-header" class="herald-responsive-header herald-slide hidden-lg hidden-md"><div class="container"><div class="herald-nav-toggle"><i class="fa fa-bars"></i></div><div class="site-branding mini"> <span class="site-title h1"><a href="https://gruntstuff.com/" rel="home"><img class="herald-logo-mini" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Gruntstuff" data-lazy-src="https://gruntstuff.com/wp-content/uploads/2019/08/Gruntstuff_logo.png" ><noscript><img class="herald-logo-mini" src="https://gruntstuff.com/wp-content/uploads/2019/08/Gruntstuff_logo.png" alt="Gruntstuff" ></noscript></a></span></div><div class="herald-menu-popup-search"> <span class="fa fa-search"></span><div class="herald-in-popup"><form class="herald-search-form" action="https://gruntstuff.com/" method="get"> <input name="s" class="herald-search-input" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="herald-search-submit"></button></form></div></div></div></div><div class="herald-mobile-nav herald-slide hidden-lg hidden-md"><ul id="menu-cat-menu-2" class="herald-mob-nav"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-90"><a href="https://gruntstuff.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92"><a href="https://gruntstuff.com/category/technology/">Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-93"><a href="https://gruntstuff.com/category/general-news/">General News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-297"><a href="https://gruntstuff.com/category/science/">Science</a></li></ul></div><div id="content" class="herald-site-content herald-slide"><div class="herald-section container "><article id="post-16221" class="herald-single post-16221 post type-post status-publish format-standard has-post-thumbnail hentry category-general-news"><div class="row"><div class="col-lg-9 col-md-9 col-mod-single col-mod-main"><header class="entry-header"> <span class="meta-category"><a href="https://gruntstuff.com/category/general-news/" class="herald-cat-4">General News</a></span><h1 class="entry-title h1">Rihanna and Drake reunite after rumored Hassan Jameel split</h1><div class="entry-meta entry-meta-single"><div class="meta-item herald-date"><span class="updated">March 21, 2020</span></div><div class="meta-item herald-comments"><a href="https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/#respond">Add Comment</a></div><div class="meta-item herald-author"><span class="vcard author"><span class="fn"><a href="https://gruntstuff.com/author/tina/">Tina Sanders</a></span></span></div><div class="meta-item herald-rtime">2 Min Read</div></div></header><div class="herald-post-thumbnail herald-post-thumbnail-single"> <span><img width="990" height="660" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20990%20660'%3E%3C/svg%3E" class="attachment-herald-lay-single size-herald-lay-single wp-post-image" alt="" data-lazy-srcset="https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?w=1200&amp;ssl=1 1200w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=414%2C276&amp;ssl=1 414w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=470%2C313&amp;ssl=1 470w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=640%2C426&amp;ssl=1 640w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=130%2C86&amp;ssl=1 130w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=187%2C124&amp;ssl=1 187w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=990%2C660&amp;ssl=1 990w" data-lazy-sizes="(max-width: 990px) 100vw, 990px" data-lazy-src="https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?fit=990%2C660&amp;ssl=1" /><noscript><img width="990" height="660" src="https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?fit=990%2C660&amp;ssl=1" class="attachment-herald-lay-single size-herald-lay-single wp-post-image" alt="" srcset="https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?w=1200&amp;ssl=1 1200w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=414%2C276&amp;ssl=1 414w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=470%2C313&amp;ssl=1 470w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=640%2C426&amp;ssl=1 640w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=130%2C86&amp;ssl=1 130w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=187%2C124&amp;ssl=1 187w, https://i2.wp.com/gruntstuff.com/wp-content/uploads/2020/03/rihanna-drake-hassan-jameel.jpg?resize=990%2C660&amp;ssl=1 990w" sizes="(max-width: 990px) 100vw, 990px" /></noscript></span></div><div class="row"><div class="col-lg-2 col-md-2 col-sm-2 hidden-xs herald-left"><div class="entry-meta-wrapper"><div class="entry-meta-author"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20112%2097'%3E%3C/svg%3E" width="112" height="97" alt="Tina Sanders" class="avatar avatar-112 wp-user-avatar wp-user-avatar-112 alignnone photo" data-lazy-src="https://i1.wp.com/gruntstuff.com/wp-content/uploads/2019/11/Tina.png?fit=112%2C97&ssl=1" /><noscript><img src="https://i1.wp.com/gruntstuff.com/wp-content/uploads/2019/11/Tina.png?fit=112%2C97&ssl=1" width="112" height="97" alt="Tina Sanders" class="avatar avatar-112 wp-user-avatar wp-user-avatar-112 alignnone photo" /></noscript> <a class="herald-author-name" href="https://gruntstuff.com/author/tina/">Tina Sanders</a></div><div class="entry-meta entry-meta-single"><div class="meta-item herald-date"><span class="updated">March 21, 2020</span></div></div><ul class="herald-share"> <span class="herald-share-meta"><i class="fa fa-share-alt"></i>Share This!</span><div class="meta-share-wrapper"><li class="facebook"> <a href="javascript:void(0);" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fgruntstuff.com%2Frihanna-and-drake-reunite-after-rumored-hassan-jameel-split%2F16221%2F&amp;t=Rihanna+and+Drake+reunite+after+rumored+Hassan+Jameel+split"><i class="fa fa-facebook"></i><span>Facebook</span></a></li><li class="twitter"> <a href="javascript:void(0);" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fgruntstuff.com%2Frihanna-and-drake-reunite-after-rumored-hassan-jameel-split%2F16221%2F&amp;text=Rihanna+and+Drake+reunite+after+rumored+Hassan+Jameel+split"><i class="fa fa-twitter"></i><span>Twitter</span></a></li><li class="gplus"> <a href="javascript:void(0);" data-url="https://plus.google.com/share?url=https%3A%2F%2Fgruntstuff.com%2Frihanna-and-drake-reunite-after-rumored-hassan-jameel-split%2F16221%2F"><i class="fa fa-google-plus"></i><span>Google Plus</span></a></li><li class="pinterest"> <a href="javascript:void(0);" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fgruntstuff.com%2Frihanna-and-drake-reunite-after-rumored-hassan-jameel-split%2F16221%2F&amp;media=https%3A%2F%2Fi2.wp.com%2Fgruntstuff.com%2Fwp-content%2Fuploads%2F2020%2F03%2Frihanna-drake-hassan-jameel.jpg%3Ffit%3D1200%252C800%26amp%3Bssl%3D1&amp;description=Rihanna+and+Drake+reunite+after+rumored+Hassan+Jameel+split"><i class="fa fa-pinterest"></i><span>Pinterest</span></a></li><li class="linkedin"> <a href="javascript:void(0);" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fgruntstuff.com%2Frihanna-and-drake-reunite-after-rumored-hassan-jameel-split%2F16221%2F&amp;title=Rihanna+and+Drake+reunite+after+rumored+Hassan+Jameel+split"><i class="fa fa-linkedin"></i><span>LinkedIn</span></a></li></div></ul></div></div><div class="col-lg-10 col-md-10 col-sm-10"><div class="entry-content herald-entry-content"><div class="92c6ac3bec2ae5f81239aeaecde4f6ab" data-index="1" style="float: none; margin:10px 0 10px 0; text-align:center;"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8917761949594759" data-ad-slot="6471164492" data-ad-format="link" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8917761949594759" data-ad-slot="2531919489" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div><div><p>Rihanna and Drake have been noticed in shut proximity to one another at Yams Day 2020 — a live performance honoring the late A$AP Mob member A$AP Yams — on Friday.</p><p>Followers <a href="https://twitter.com/PopCrave/status/1219097834814918656?">captured a video</a> that exhibits the exes standing close to one another within the crowd as they took in one of many performances.</p><div class="92c6ac3bec2ae5f81239aeaecde4f6ab" data-index="2" style="float: none; margin:0px 0 0px 0; text-align:center;"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8917761949594759" data-ad-slot="2531919489" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div><p>It’s unclear whether or not the pair arrived collectively or spoke on the occasion, nevertheless it’s possible they crossed paths as a result of they have been just a few ft away from one another.</p><p>The timing of their reunion sparked rumors that the exes could also be rekindling a romance because it was just lately reported that Rihanna, 31, is newly single.</p><div class="92c6ac3bec2ae5f81239aeaecde4f6ab" data-index="2" style="float: none; margin:0px 0 0px 0; text-align:center;"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8917761949594759" data-ad-slot="2531919489" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div><p>Nonetheless, a supply advised us they&#8217;re “not courting.”</p><p>A rep for Drake declined to remark and Rihanna’s rep didn&#8217;t return our requests.</p><div class="92c6ac3bec2ae5f81239aeaecde4f6ab" data-index="3" style="float: none; margin:10px 0 10px 0; text-align:center;"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8917761949594759" data-ad-slot="6471164492" data-ad-format="link" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8917761949594759" data-ad-slot="2531919489" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div><p>In response to Us Weekly, the “Love on the Mind” singer just lately split from her billionaire boyfriend, Hassan Jameel, after three years of courting.</p><p>The pair have been first linked in June 2017 when Rihanna was noticed hooking up with the 31-year-old Saudi Arabian businessman whereas on trip in Spain.</p><p>Drake, 33, and Rihanna have been rumored to have been courting off and on in 2016.</p><p>Nonetheless, Rihanna advised Vogue in Might 2018, “We don’t have a friendship now, however we’re not enemies both. It&#8217;s what it&#8217;s.”</p></p></div><p></p><div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div class="hatom-extra" style="display:none;visibility:hidden;"><span class="entry-title">Rihanna and Drake reunite after rumored Hassan Jameel split</span> was last modified: <span class="updated"> March 21st, 2020</span> by <span class="author vcard"><span class="fn">Tina Sanders</span></span></div></div></div><div id="extras" class="col-lg-12 col-md-12 col-sm-12"><div id="related" class="herald-related-wrapper"><div class="herald-mod-wrap"><div class="herald-mod-head "><div class="herald-mod-title"><h4 class="h6 herald-mod-h herald-color">You may also like</h4></div></div></div><div class="herald-related row row-eq-height"><article class="herald-lay-f herald-lay-f1 post-16215 post type-post status-publish format-standard has-post-thumbnail hentry category-general-news"><div class="herald-ovrld"><div class="herald-post-thumbnail"> <a href="https://gruntstuff.com/elizabeth-warren-bernie-sanders-told-me-a-woman-would-not-be-elected-president/16215/" title="Elizabeth Warren: Bernie Sanders told me a woman would not be elected president"><img width="300" height="200" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20200'%3E%3C/svg%3E" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" alt="" data-lazy-srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?w=1200&amp;ssl=1 1200w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=640%2C426&amp;ssl=1 640w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=990%2C660&amp;ssl=1 990w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=300%2C200&amp;ssl=1" /><noscript><img width="300" height="200" src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=300%2C200&amp;ssl=1" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" alt="" srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?w=1200&amp;ssl=1 1200w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=640%2C426&amp;ssl=1 640w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/warren-sanders.jpg?resize=990%2C660&amp;ssl=1 990w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></div><div class="entry-header"> <span class="meta-category"><a href="https://gruntstuff.com/category/general-news/" class="herald-cat-4">General News</a></span><h2 class="entry-title h6"><a href="https://gruntstuff.com/elizabeth-warren-bernie-sanders-told-me-a-woman-would-not-be-elected-president/16215/">Elizabeth Warren: Bernie Sanders told me a woman would not be elected president</a></h2><div class="entry-meta"><div class="meta-item herald-date"><span class="updated">March 21, 2020</span></div></div></div></div></article><article class="herald-lay-f herald-lay-f1 post-16212 post type-post status-publish format-standard has-post-thumbnail hentry category-general-news"><div class="herald-ovrld"><div class="herald-post-thumbnail"> <a href="https://gruntstuff.com/high-school-basketball-coach-accused-of-groping-14-year-old-student/16212/" title="High school basketball coach accused of groping 14-year-old student"><img width="300" height="200" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20200'%3E%3C/svg%3E" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" alt="" data-lazy-srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?w=1200&amp;ssl=1 1200w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=640%2C426&amp;ssl=1 640w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=990%2C660&amp;ssl=1 990w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=300%2C200&amp;ssl=1" /><noscript><img width="300" height="200" src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=300%2C200&amp;ssl=1" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" alt="" srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?w=1200&amp;ssl=1 1200w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=640%2C426&amp;ssl=1 640w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/200113-elijah-kim-fullerton.jpg?resize=990%2C660&amp;ssl=1 990w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></div><div class="entry-header"> <span class="meta-category"><a href="https://gruntstuff.com/category/general-news/" class="herald-cat-4">General News</a></span><h2 class="entry-title h6"><a href="https://gruntstuff.com/high-school-basketball-coach-accused-of-groping-14-year-old-student/16212/">High school basketball coach accused of groping 14-year-old student</a></h2><div class="entry-meta"><div class="meta-item herald-date"><span class="updated">March 21, 2020</span></div></div></div></div></article><article class="herald-lay-f herald-lay-f1 post-16209 post type-post status-publish format-standard has-post-thumbnail hentry category-general-news"><div class="herald-ovrld"><div class="herald-post-thumbnail"> <a href="https://gruntstuff.com/porsha-williams-shares-a-video-with-baby-pj-terrorizing-her-and-fans-are-in-awe/16209/" title="Porsha Williams Shares A Video With Baby PJ Terrorizing Her And Fans Are In Awe"><img width="300" height="200" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20200'%3E%3C/svg%3E" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" alt="" data-lazy-srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=640%2C426&amp;ssl=1 640w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?zoom=3&amp;resize=300%2C200&amp;ssl=1 900w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=300%2C200&amp;ssl=1" /><noscript><img width="300" height="200" src="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=300%2C200&amp;ssl=1" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" alt="" srcset="https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=640%2C426&amp;ssl=1 640w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/gruntstuff.com/wp-content/uploads/2020/03/Porsha-Williams8217-Recent-Photo-Of-Pilar-Jhena-McKinley-Shows-Fans-How-Beautiful-The-Baby-Girl-Is.jpg?zoom=3&amp;resize=300%2C200&amp;ssl=1 900w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></div><div class="entry-header"> <span class="meta-category"><a href="https://gruntstuff.com/category/general-news/" class="herald-cat-4">General News</a></span><h2 class="entry-title h6"><a href="https://gruntstuff.com/porsha-williams-shares-a-video-with-baby-pj-terrorizing-her-and-fans-are-in-awe/16209/">Porsha Williams Shares A Video With Baby PJ Terrorizing Her And Fans Are In Awe</a></h2><div class="entry-meta"><div class="meta-item herald-date"><span class="updated">March 21, 2020</span></div></div></div></div></article></div></div><div id="author" class="herald-vertical-padding"><div class="herald-mod-wrap"><div class="herald-mod-head "><div class="herald-mod-title"><h4 class="h6 herald-mod-h herald-color">About the author</h4></div><div class="herald-mod-actions"><a href="https://gruntstuff.com/author/tina/">View All Posts</a></div></div></div><div class="herald-author row"><div class="herald-author-data col-lg-2 col-md-2 col-sm-2 col-xs-2"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20140%20121'%3E%3C/svg%3E" width="140" height="121" alt="Tina Sanders" class="avatar avatar-140 wp-user-avatar wp-user-avatar-140 alignnone photo" data-lazy-src="https://i1.wp.com/gruntstuff.com/wp-content/uploads/2019/11/Tina.png?fit=140%2C121&ssl=1" /><noscript><img src="https://i1.wp.com/gruntstuff.com/wp-content/uploads/2019/11/Tina.png?fit=140%2C121&ssl=1" width="140" height="121" alt="Tina Sanders" class="avatar avatar-140 wp-user-avatar wp-user-avatar-140 alignnone photo" /></noscript></div><div class="herald-data-content col-lg-10 col-md-10 col-sm-10 col-xs-10"><h4 class="author-title">Tina Sanders</h4><p>Tina is the mind behind Gruntstuff.com, and she ideated it when she was working for an online magazine company where she used to cover US-based headlines news. She holds a degree in journalism and has more than 4.5 years of experience in an online magazine company. She had the idea while working there but when she was quite sure about starting something on her own, she took the risk and left the job to start Gruntstuff. Since then she added a few team members, and along with them, she creates General US news content on the site.</p></div></div></div><div id="comments" class="herald-comments"><div class="herald-mod-wrap"><div class="herald-mod-head "><div class="herald-mod-title"><h4 class="h6 herald-mod-h herald-color">Add Comment</h4></div></div></div><div class="herald-gray-area"><span class="herald-fake-button herald-comment-form-open">Click here to post a comment</span></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://gruntstuff.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name<span class="required"> *</span></label> <input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p><p class="comment-form-email"><label for="email">Email<span class="required"> *</span></label> <input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p><p class="comment-form-url"><label for="url">Website</label><input id="url" name="url" type="text" value="" size="30" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post comment" /> <input type='hidden' name='comment_post_ID' value='16221' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="3be5f595e8" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="79"/></p></form></div></div><div id="single-sticky" class="herald-single-sticky herald-single-wraper hidden-xs hidden-sm"><div class="container"><div class="row"><div class="col-lg-12 col-md-12"><div class="herald-sticky-prev h6"> <a href="https://gruntstuff.com/lala-kent-heres-why-she-was-not-fazed-by-50-cents-latest-diss-of-her-postponed-marriage-ceremony/16218/" rel="prev">Lala Kent – Here’s Why She Was Not Fazed By 50 Cent’s Latest Diss Of Her Postponed Marriage ceremony!</a></div><div class="herald-sticky-share"> <a href="https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/#respond" class="herald-comment-action" >Comment</a><ul class="herald-share"> <span class="herald-share-meta"><i class="fa fa-share-alt"></i>Share This!</span><div class="meta-share-wrapper"><li class="facebook"> <a href="javascript:void(0);" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fgruntstuff.com%2Frihanna-and-drake-reunite-after-rumored-hassan-jameel-split%2F16221%2F&amp;t=Rihanna+and+Drake+reunite+after+rumored+Hassan+Jameel+split"><i class="fa fa-facebook"></i><span>Facebook</span></a></li><li class="twitter"> <a href="javascript:void(0);" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fgruntstuff.com%2Frihanna-and-drake-reunite-after-rumored-hassan-jameel-split%2F16221%2F&amp;text=Rihanna+and+Drake+reunite+after+rumored+Hassan+Jameel+split"><i class="fa fa-twitter"></i><span>Twitter</span></a></li><li class="gplus"> <a href="javascript:void(0);" data-url="https://plus.google.com/share?url=https%3A%2F%2Fgruntstuff.com%2Frihanna-and-drake-reunite-after-rumored-hassan-jameel-split%2F16221%2F"><i class="fa fa-google-plus"></i><span>Google Plus</span></a></li><li class="pinterest"> <a href="javascript:void(0);" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fgruntstuff.com%2Frihanna-and-drake-reunite-after-rumored-hassan-jameel-split%2F16221%2F&amp;media=https%3A%2F%2Fi2.wp.com%2Fgruntstuff.com%2Fwp-content%2Fuploads%2F2020%2F03%2Frihanna-drake-hassan-jameel.jpg%3Ffit%3D1200%252C800%26amp%3Bssl%3D1&amp;description=Rihanna+and+Drake+reunite+after+rumored+Hassan+Jameel+split"><i class="fa fa-pinterest"></i><span>Pinterest</span></a></li><li class="linkedin"> <a href="javascript:void(0);" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fgruntstuff.com%2Frihanna-and-drake-reunite-after-rumored-hassan-jameel-split%2F16221%2F&amp;title=Rihanna+and+Drake+reunite+after+rumored+Hassan+Jameel+split"><i class="fa fa-linkedin"></i><span>LinkedIn</span></a></li></div></ul></div></div></div></div></div></div></div></div><div class="herald-sidebar col-lg-3 col-md-3 herald-sidebar-right"><div id="search-2" class="widget widget_search"><h4 class="widget-title h6"><span>Search</span></h4><form class="herald-search-form" action="https://gruntstuff.com/" method="get"> <input name="s" class="herald-search-input" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="herald-search-submit"></button></form></div><div id="text-2" class="widget widget_text"><h4 class="widget-title h6"><span>Get in Touch!</span></h4><div class="textwidget"><p>For any queries or feedback, please get in touch at <a href="/cdn-cgi/l/email-protection#3253565f5b5c725540475c4641464754541c515d5f"><span class="__cf_email__" data-cfemail="98f9fcf5f1f6d8ffeaedf6ecebecedfefeb6fbf7f5">[email&#160;protected]</span></a>. We respond to queries within 24 x 48 hours.</p></div></div><div id="categories-2" class="widget widget_categories"><h4 class="widget-title h6"><span>Topics</span></h4><ul><li class="cat-item cat-item-4"><a href="https://gruntstuff.com/category/general-news/"><span class="category-text">General News</span></a></li><li class="cat-item cat-item-46"><a href="https://gruntstuff.com/category/science/"><span class="category-text">Science</span></a></li><li class="cat-item cat-item-3"><a href="https://gruntstuff.com/category/technology/"><span class="category-text">Technology</span></a></li></ul></div><div id="recent-posts-2" class="widget widget_recent_entries"><h4 class="widget-title h6"><span>Recent News</span></h4><ul><li> <a href="https://gruntstuff.com/rihanna-and-drake-reunite-after-rumored-hassan-jameel-split/16221/" aria-current="page">Rihanna and Drake reunite after rumored Hassan Jameel split</a></li><li> <a href="https://gruntstuff.com/lala-kent-heres-why-she-was-not-fazed-by-50-cents-latest-diss-of-her-postponed-marriage-ceremony/16218/">Lala Kent – Here’s Why She Was Not Fazed By 50 Cent’s Latest Diss Of Her Postponed Marriage ceremony!</a></li><li> <a href="https://gruntstuff.com/elizabeth-warren-bernie-sanders-told-me-a-woman-would-not-be-elected-president/16215/">Elizabeth Warren: Bernie Sanders told me a woman would not be elected president</a></li><li> <a href="https://gruntstuff.com/high-school-basketball-coach-accused-of-groping-14-year-old-student/16212/">High school basketball coach accused of groping 14-year-old student</a></li><li> <a href="https://gruntstuff.com/porsha-williams-shares-a-video-with-baby-pj-terrorizing-her-and-fans-are-in-awe/16209/">Porsha Williams Shares A Video With Baby PJ Terrorizing Her And Fans Are In Awe</a></li><li> <a href="https://gruntstuff.com/new-surprise-woman-1984-image-shows-cheetah-maxwell-lord-together/16206/">New ‘Surprise Woman 1984’ Image Shows Cheetah &#038; Maxwell Lord Together</a></li><li> <a href="https://gruntstuff.com/disney-warns-that-coronavirus-is-making-it-hard-to-predict-future-performance/16203/">Disney warns that coronavirus is making it hard to predict future performance</a></li><li> <a href="https://gruntstuff.com/south-carolina-english-teacher-allegedly-had-sex-with-16-year-old-student/16200/">South Carolina English teacher allegedly had sex with 16-year-old student</a></li><li> <a href="https://gruntstuff.com/arrow-star-stephen-amell-suffers-panic-attack-in-the-middle-of-podcast/16197/">‘Arrow’ star Stephen Amell suffers panic attack in the middle of podcast</a></li><li> <a href="https://gruntstuff.com/the-insane-moment-a-man-tries-to-kidnap-lady-6-and-is-taken-down-by-her-family/16194/">The insane moment a man tries to kidnap lady, 6, and is taken down by her family</a></li><li> <a href="https://gruntstuff.com/wildlife-group-saves-baby-opossum-found-beaten-blind-at-golf-course/16191/">Wildlife group saves baby opossum found beaten blind at golf course</a></li><li> <a href="https://gruntstuff.com/harvey-weinsteins-11th-hour-bid-to-move-trial-from-nyc-denied/16188/">Harvey Weinstein’s 11th-hour bid to move trial from NYC denied</a></li><li> <a href="https://gruntstuff.com/david-adefeso-praises-tamar-braxtons-new-music-ive-been-waiting-on-this-the-last-two-years/16185/">David Adefeso Praises Tamar Braxton’s New Music: ‘I’ve Been Waiting On This The Last Two Years’</a></li><li> <a href="https://gruntstuff.com/new-york-gov-cuomo-holds-a-press-conference-on-the-coronavirus-outbreak/16182/">New York Gov. Cuomo holds a press conference on the coronavirus outbreak</a></li><li> <a href="https://gruntstuff.com/teenage-bullies-accused-of-breaking-moms-nose-in-vicious-beating/16179/">Teenage bullies accused of breaking mom’s nose in vicious beating</a></li><li> <a href="https://gruntstuff.com/jerry-oconnell-jokes-that-he-and-rebecca-romijn-role-play-as-joe-and-teresa-giudice/16176/">Jerry O’Connell jokes that he and Rebecca Romijn role-play as Joe and Teresa Giudice</a></li><li> <a href="https://gruntstuff.com/mama-junes-fans-express-their-concerns-over-her-missing-tooth-in-video-advert/16173/">Mama June’s Fans Express Their Concerns Over Her Missing Tooth In Video Advert!</a></li><li> <a href="https://gruntstuff.com/netflix-establishes-coronavirus-relief-fund-for-out-of-work-employees/16171/">Netflix Establishes Coronavirus Relief Fund For Out Of Work Employees</a></li><li> <a href="https://gruntstuff.com/supreme-court-denies-to-hear-appeal-from-free-the-nipple-activists/16168/">Supreme Court denies to hear appeal from ‘Free the Nipple’ activists</a></li><li> <a href="https://gruntstuff.com/wyatt-russell-spotted-filming-the-falcon-and-the-winter-soldier-series/16165/">Wyatt Russell spotted filming ‘The Falcon and the Winter Soldier’ series</a></li></ul></div></div></div></article></div></div><footer id="footer" class="herald-site-footer herald-slide"><div class="footer-widgets container"><div class="row"><div class="col-lg-3 col-md-3 col-sm-3"></div><div class="col-lg-3 col-md-3 col-sm-3"></div><div class="col-lg-3 col-md-3 col-sm-3"></div><div class="col-lg-3 col-md-3 col-sm-3"></div></div></div><div class="footer-bottom"><div class="container"><div class="row"><div class="col-lg-12"><div class="hel-l herald-go-hor"><div class="herald-copyright">Copyright &copy; 2019, Gruntstuff</div></div><div class="hel-r herald-go-hor"></div></div></div></div></div></footer>  <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>/* <![CDATA[ */ var wpcf7 = {"apiSettings":{"root":"https:\/\/gruntstuff.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"}; /* ]]> */</script>   <script type='text/javascript'>/* <![CDATA[ */ var herald_js_settings = {"ajax_url":"https:\/\/gruntstuff.com\/wp-admin\/admin-ajax.php","rtl_mode":"false","header_sticky":"1","header_sticky_offset":"600","header_sticky_up":"","single_sticky_bar":"1","popup_img":"1","logo":"https:\/\/gruntstuff.com\/wp-content\/uploads\/2019\/08\/Gruntstuff_logo.png","logo_retina":"https:\/\/gruntstuff.com\/wp-content\/uploads\/2019\/08\/Gruntstuff_logo.png","logo_mini":"https:\/\/gruntstuff.com\/wp-content\/uploads\/2019\/08\/Gruntstuff_logo.png","logo_mini_retina":"https:\/\/gruntstuff.com\/wp-content\/uploads\/2019\/08\/Gruntstuff_logo.png","smooth_scroll":""}; /* ]]> */</script>    <script type='text/javascript' src='https://stats.wp.com/e-202012.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.2.1',blog:'63604248',post:'16221',tz:'0',srv:'gruntstuff.com'} ]);
	_stq.push([ 'clickTrackerInit', '63604248', '16221' ]);</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://gruntstuff.com/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script> <script data-no-minify="1" async src="https://gruntstuff.com/wp-content/cache/busting/1/gtm-e1458a4e6a1af72ac951d9d4c9aa30a3.js"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-154877437-1');</script> <script src="https://gruntstuff.com/wp-content/cache/min/1/cca60ef1f77906741a111119848a4e68.js" data-minify="1" defer></script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1584768692 -->